Useful Fix

[Guide]How to change your processor name in Big Sur

The old method is not working on macOS BigSur. However, we can fix the Unknown CPU name or change it to any CPU type you want. I will describe this simple method using terminal code.

1. Access the root folder

a) Replace the value in Config.plist>>NVRAM>>Add>>7C436110-….9f82>>csr-active-config>>FF0F0000 then reboot in to Recovery mode. (This will break your OS update, so you should bring it back to 00000000 if you need the update.)

b) In recovery mode, open Terminal app in Utility tab. Type codes below:

csrutil disable
csrutil authenticated-root disable

c) You will see successful messages. Reboot. (If you want SIP enable, use ‘enable’ with the same codes rather than ‘disable’.

d) Open Terminal app. Type codes below:

mkdir ~/livemount
diskutil

e) Find your BigSur drive’s identifier in the list and mount it with code below:

(In my case, disk4s1 is my BigSur drive)

sudo mount -o nobrowse -t apfs /dev/disk4s1 ~/livemount

d) Now you should see your BigSur Drive in your USER’s name folder.

2. Edit your CPU Type

a) Use codes below to copy your AppleSystemInfo.strings file to Desktop:

cp /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/en.lproj/AppleSystemInfo.strings ~/Desktop/

(Note that the following example is only valid for systems with English as the main system language. If your system language is German, French, Spanish, Chinese etc., substitute “en.lproj” in the individual commands by the “lproj” of your System language!)

b) Open the copied file in the desktop with BBEdit app. Find <key>UnknownCPUKind</key> and replace <string>Unknown</string> to what Name you want. Save it.

c) Open Config.plist>>PlatformInfo>>Generic>>ProcessorType>>2000 (default is ‘0’). Save it.

3. Replace edited AppleSystemInfo.strings to your mounted Drive

a) Use the code below in the Terminal App:

sudo cp ~/Desktop/AppleSystemInfo.strings ~/livemount/System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/en.lproj/

(Again, use your system language’s lproj if your system language is not English)

4. Create a Snapshot

a) Use the code below:

sudo bless --folder ~/livemount/System/Library/CoreServices --bootefi --create-snapshot

b) Reboot!

Last modified: January 12, 2021

avatar
1 Comment threads
0 Thread replies
2 Followers
 
Most reacted comment
Hottest comment thread
0 Comment authors
Recent comment authors
  Subscribe  
newest oldest most voted
Notify of
trackback
fake igpu/cpu name – every thing for hackintosher

[…] ⇒ NVRAM ⇒ Add ⇒ 7C436110-….9f82 ⇒ csr-active-config ⇒ 00000000 ( main source : [Guide]How to change your processor name in Big Sur – Climb Joe’s Coffee Break ) các này chỉ dành cho những bạn thích màu mè nó chỉ đổi tên cpu ở about this […]